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Introduction

Welcome to ReActiv®, the reinforced slope design program. ReActiv is an
interactive program that helps you to design reinforced slopes in a variety of
different soil types, using reinforced soil or soil nails.

This chapter of the ReActiv User Manual outlines the contents of this book, explains
the conventions that are used herein, and tells you what to do if you need help
using the program.

About this book

This User Manual is divided into the following chapters:

• Introduction

• Overview

• Calculating mechanisms

• Calculating the required reinforcement
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Conventions

To help you locate and interpret information easily, the ReActiv User Manual uses
the following typographical conventions.

This Represents

Bold Items on a menu or in a list-box; the text on a button or
next to an edit control; or the label of a group box.

Item1 > Item2 An item on a cascading menu. Item1 is the name of an
option on the main menu bar (such as File or
Window); and Item2 is the name of an option on the
cascading menu that appears when you select Item1
(such as New or Open). Thus, File > New represents
the New command from the File menu.

italic Placeholders for information you must provide. For
example, if you are asked to type filename, you should
type the actual name for a file instead of the word
shown in italics.

Italic type also signals a new term. An explanation
immediately follows the italicized term.

monospaced Anything you must type on the keyboard.

CAPITALS Directory names, filenames, and acronyms.

KEY1+KEY2 An instruction to press and hold down key 1 before
pressing key 2. For example, "ALT+ESC" means press
and hold down the ALT key before pressing the ESC
key. Then release both keys.

KEY1, KEY2 An instruction to press and release key 1 before
pressing key 2. For example, "ALT, F" means press and
release the ALT key before pressing and releasing the F
key.
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Where to go for help

Your first source of help and information should be this manual and the ReActiv’s
extensive help system.

ReActiv’s help system

ReActiv’s help system contains detailed information about all aspects of the
program. Help appears in a separate window with its own controls. Help topics
that explain how to accomplish a task appear in windows that you can leave
displayed while you follow the procedure.

To open the help system:

● Press F1

● Click the Help button in any dialog box

● Choose a command from the Help menu

If you need assistance with using the help system, choose the How To Use Help
command from the Help menu.
Tooltips
If you pause while passing the mouse pointer over an object, such as a toolbar
button, ReActiv displays the name of that object. This feature, called tooltips, makes
it easier for you to identify what you see and to find what you need.

Software Re-Assurance™ 

Software Re-assurance for ReActiv (including updates, upgrades, and technical
support) is available direct from Geocentrix. If you require Re-Assurance, please
contact Geocentrix as follows:

ReActiv Technical Support
Geocentrix Ltd
Scenic House, 54 Wilmot Way
Banstead, Surrey
SM7 2PY, United Kingdom

Please quote your licence number
and on all correspondence

T: +44 (0)1737 373963
E: support@geocentrix.co.uk
W: www.geocentrix.co.uk/support

Please be at your computer and have
your licence number ready when you
call

mailto:support@geocentrix.co.uk
http://www.geocentrix.co.uk
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Sales and marketing information

For sales and marketing information about ReActiv, please visit

http://www.geocentrix.co.uk/reactiv/index.html

or contact ReActiv Sales on the same numbers as above.

Documentation

The latest version of this User Manual (including any corrections and/or additions
since the program’s first release) are available in electronic (Adobe® Acrobat®)
format from the Geocentrix website (www.geocentrix.co.uk/reactiv) and follow
links to ReActiv’s documentation.

Notes
The screenshots in this guide were produced on Windows 10. Your screen may
differ, depending on the version of Windows on which you run ReActiv. Not all
options are available in every edition of ReActiv.

In this guide, ‘[Documents]’ refers to the folder where your ReActiv projects are
saved. For Windows 10 this is:

C:\Users\Public\Documents\Geocentrix\ReActiv\2.0

On Windows XP, replace:

C:\Users\Public\Documents

with:
C:\Documents and Settings\All Users\Shared Documents

http://www.geocentrix.co.uk/reactiv/index.html
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Overview

This chapter of the ReActiv User Manual provides an overview of ReActiv. It
describes the main features of the program and the most commonly used
commands.

ReActiv implements and extends the design method given in the UK Highways
Agency’s Advice Note HA68 on Design methods for the reinforcement of highway
slopes by reinforced soil and soil nailing techniques (1994), which can be found in
the HA’s Design manual for roads and bridges, Volume 4 Geotechnics and drainage,
Section 1 Earthworks, Part 4. For brevity, this document is referred to herein as the
Advice Note. Chapter 8 explains the background theory and assumptions behind
the Advice Note.

ReActiv divides the display of information about your reinforced slope problem
between three main views:

● The Job View — allows you to define the problem that you want to analyse

● The Mechanisms View — displays the results of calculations using the two-
part wedge mechanism

● The Reinforcement View — gives a preliminary layout of the reinforcement
that will be required

Each of these views is displayed in its own window, which fits inside ReActiv’s
Frame Window. The Frame Window serves as a desktop on which all other views
and windows are arranged.

The following sections describe the various views and windows in turn.

Job View

The Job View is place where you enter information that defines your reinforced
slope problem. ReActiv provides you with continuous feedback as you enter this
information, by displaying an up-to-date picture of the slope being analysed,
including the soil column, water table, and any surcharge applied to the slope.
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Slope

The slope is shown at the centre of the Job View and is drawn to a true scale. The
names given to various parts of the slope are indicated below.

Soil column

The Selected Soil (see page 16) is shown by the soil column near the left hand
edge of the Job View. The symbol used to represent the Selected Soil depends
on its classification.

The soil column is drawn to a true vertical scale.

Water regime

The slope’s water regime is represented by Bishop’s pore pressure parameter (ru).
The current value of ru is displayed underneath the slope’s baseline.
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Surcharge

Surcharges are shown by (red) down-pointing arrows. They can be
applied to the horizontal crest of One- or Two-part slopes or to the
sloping crest of Infinite slopes. They cannot be applied to the lower
part of any slope or the upper part of a Two-part slope.

The magnitude of the surcharge appears above the surcharge symbol.

Datum line

If the appropriate option on the View menu is selected, a datum line is drawn
vertically through the toe of the slope. The datum line is coloured grey.

Rulers

Heights above ground level can be measured using the vertical ruler that
appears along the left hand edge of the Job View (if the appropriate
option on the View menu is selected). Similarly, horizontal distances can
be measured using the horizontal ruler that appears along the top edge
of the Job View.

You can change the scale of the rulers (and hence the size of the drawing
in the Job View) by:

● Positioning the mouse pointer over one of the rulers and then
clicking the right mouse button. A pop-up menu appears. Choose
the scale you want from those listed

● Choosing one of the scales on the View menu

● Choosing Zoom In or Zoom Out on the View menu to change
the scale to its next level up or down

● Clicking on the Zoom In or Zoom Out buttons on the Toolbar

The scales that ReActiv provides are:

● 1:50

● 1:100

● 1:250



P a g e  |  1 2  R e A c t i v  2  U s e r  M a n u a l

● 1:500

Managers

ReActiv’s Managers are floating dialog boxes that allow you to add, edit, and delete
objects with a minimum of effort. Each Manager displays a list of all the objects of
a particular type you have defined. See page 15 for further information about
ReActiv’s Soil Manager and page 19 for ReActiv’s Reinforcement Manager.

Mechanisms View

The Mechanisms View displays the results of your calculations using the two-part
wedge mechanism described in Chapter 2.

The purpose of the calculations is to find the largest out-of-balance force that must
be resisted by the reinforcement in order to stabilize the slope. ReActiv allows you
to calculate:

● The out-of-balance force (T) for an individual mechanism

● The largest out-of-balance force for the fan of mechanisms that emanates
from each point on a search grid

● The greatest out-of-balance force of any mechanism in the slope (the Tmax-
mechanism) — see Chapter 7

● The basal mechanism that has an out-of-balance force of zero (the Tob-
mechanism) — see Chapter 7
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The Mechanisms View displays the results of these calculations in a spreadsheet
containing, for each mechanism:

● The X- and Y- coordinate of the mechanism’s heel

● The angle of the upper wedge

● The out-of-balance force

● Notes indicating the type of mechanism (see Chapter 7), whether the
mechanism is a critical mechanism (see Chapter 7), the Tmax, or the Tob

mechanism

● (Optionally) The type of mechanism (see Chapter 7)

Reinforcement View

The Reinforcement View displays the reinforcement layout required to stabilize the
slope.

The suggested layout is suitable for preliminary design. The procedure for
establishing a final design is discussed in Chapter 9.

For each layer of reinforcement in the suggested layout, ReActiv displays:

● The name of the reinforcement

● The reinforcement type (Geotextile, Geogrid, Soil Nails or User-defined)



P a g e  |  1 4  R e A c t i v  2  U s e r  M a n u a l

● The strength of the reinforcement

● The depth of the layer

● The length of the reinforcement

● The reinforcement’s inclination

● Notes giving special information relevant to that layer (for example, in the
case of soil nails, the horizontal spacing of the nails)

Toolbar

The Toolbar provides mouse-users with quick access to commonly used menu
commands.

To find out what each button does, refer to ReActiv’s help system or place the
mouse pointer over each button in turn and read the tooltip (description) that
appears after a short delay.

Status Bar

The Status Bar provides a summary of the key information that you will require
when working in each of ReActiv’s views.

The Status Bar changes as you move from one view to another and reflects the
information that you have entered into the program.

The Status Bar also provides an explanation of menu commands as you scroll
through them and descriptions of what the buttons on the Toolbar do as you move
the mouse pointer over them.

Soils

ReActiv implements seven types of soil:

● Gravel

● Sand

● Silt
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● Clay

● Fill

● Chalk

● Custom

Soil Manager

ReActiv’s Soil Manager makes it easy to add, edit, and delete soils. The Soil
Manager is a floating dialog box that remains on top of all other windows until you
choose to close it. The Soil Manager displays the names of every soil that has been
created in the current job, and provides buttons that duplicate commands on the
Soil menu.

If it is not already showing, you can display the Soil Manager by:

● Ticking View > Soil Manager on the Job View’s menu bar

● Clicking on the Soil Manager button on the Toolbar

You can close the Soil Manager by:

● Unticking View | Soil Manager on the Job View’s menu bar

● Clicking on the Soil Manager button on the Toolbar

● Choosing the Close command from the Soil Manager’s control menu

You can move the Soil Manager around the screen in the usual ways, by dragging
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its title bar with the mouse or by choosing the Move command from the Soil
Manager’s control menu and then using the appropriate cursor keys.

Soil classification system and database

ReActiv uses the information you provide about a soil’s classification to check the
parameters that you enter via the Soil Properties dialog box.

ReActiv uses the Soil Classification System that was introduced in ReWaRD®, our
retaining wall research and design program. The Soil Classification System provides
a comprehensive and systematic description of commonly-encountered soil types
and is linked to an extensive database of peak and critical state soil parameters.

In the Soil Classification System, each soil is classified according to three main
descriptors:

● Group

● Class (depends on Group)

● State (depends on Group and Class)

Chapter 13 lists the various Groups, Classes, and States that ReActiv recognizes
and compares them with established soil classification systems.

The selected soil

Although you may define the properties of more than one soil, only one soil is used
by the program at any one time. This soil is known as the Selected Soil.

You may choose the Selected Soil by choosing Slope | Selected Soil... from the Job
View’s menu bar. Select one of the soils listed in the listbox and click the OK
button, ReActiv re-draws the soil column (if displayed) to reflect the soil you have
selected.

Design parameters

When ReActiv performs its calculations, it uses design values of the key soil
parameters rather than characteristic values. The design value of the soil’s angle of
shearing resistance (φ) is given by:
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and the design value of the soil’s effective cohesion (cʹ) is given by:

If you specify critical state parameters, ReActiv sets the partial factors in these
equations to 1.0.

Slopes

ReActiv implements three types of slope:

● One-part

● Two-part

● Infinite

Stability of upper slopes/crests

The  upper slope of Two-part slopes and the sloping crest of Infinite slopes are
potentially unstable when:

where ru is Bishop’s pore pressure parameter, and φ is the soil’s angle of shearing
resistance. The angle i is given by:

● For Two-part slopes, the angle of the upper slope

● For Infinite slopes, the crest angle

ReActiv checks for potential instability of the upper slope or sloping crest when it
validates the parameters you enter into the slope’s property box. However, even
if the slope is unstable, ReActiv allows you calculate the reinforcement required to
stabilize the lower slope on the assumption that you will analyse the stability of the
upper slope/sloping crest as a separate exercise. If you do this using ReActiv, then
you should treat the reinforced lower slope as a competent foundation to the
upper slope/sloping crest.
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Water regimes

ReActiv implements four types of water regime:

● Parallel

● Horizontal

● Parabolic

● Custom

For water regimes other than custom, ReActiv calculates Bishop’s pore pressure
parameter (ru) for you, using the formula given by Mitchell (1983), Earth structures
engineering, Allen & Unwin Inc., Boston, p128.

Parallel water regime

For parallel water regimes, Bishop’s pore pressure parameter (ru) is  given by:

where γw is the unit weight of water; γ is the unit weight of the selected soil (see
page 16); and β is the angle of the lower slope.

Horizontal water regime

For horizontal water regimes, Bishop’s pore pressure parameter (ru) is given by:

where γw and γ are defined above.

Parabolic water regime

For parabolic water regimes, Bishop’s pore pressure parameter (ru) is given by:

where γw, γ, and β are defined above.
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Reinforcements

ReActiv implements four types of reinforcement:

● Geotextiles

● Geogrids

● Soil nails

● Custom

Reinforcement Manager

ReActiv’s Reinforcement Manager makes it easy to add, edit, and delete
reinforcements. The Reinforcement Manager is a floating dialog box that remains
on top of all other windows until you choose to close it. The Reinforcement
Manager displays the names of every reinforcement that has been created in the
current job.

If it is not already showing, you can display the Reinforcement Manager by:

● Ticking View > Reinforcement Manager on the Job View’s menu bar

● Clicking on the Reinforcement Manager button on the Toolbar

You can close the Reinforcement Manager by:

● Unticking View > Reinforcement Manager on the Job View’s menu bar

● Clicking on the Reinforcement Manager button on the Toolbar



P a g e  |  2 0  R e A c t i v  2  U s e r  M a n u a l

● Choosing the Close command from the Reinforcement Manager’s control
menu

Design strength

The design strength (Pdes) that you enter into ReActiv is the long-term factored
design strength of the reinforcement per unit width of slope (in kN/m).

According to the Advice Note, the design strength should be derived from the
unfactored long-term characteristic strength of the reinforcement (Pc) by applying
a set of partial safety factors as follows:

where fd is a factor-of-safety against mechanical damage before and during
installation; fe is a factor-of-safety against environmental (chemical and biological)
effects during the reinforcement’s design life; and fm is a factor-of-safety to cover
uncertainties in material strength (including extrapolation of data).

Values for Pc, fd, fe, and fm may be taken from the BBA certificate or manufacturer’s
literature for the reinforcement.

Further guidance is available in the CIRIA Special Publication 123, Soil
reinforcement with geotextiles, by RA Jewell (1996).

Design factors

ReActiv requires you to specify certain design factors that govern the base-sliding
and pullout resistance of the reinforcement. The direct-shear factor is used in
calculations which involve sliding of soil over the surface of the reinforcement,
whereas the bearing factor is used in calculations involving local bearing failure on
the ribs of geogrids or custom reinforcement.

Geotextiles

ReActiv uses the direct-shear factor to calculate the resistance that a geotextile
provides against base-sliding and also — since pullout failure of a geotextile involves
sliding along both its sides — its pullout resistance.

Geogrids

ReActiv uses the direct-shear factor to calculate the resistance that a geogrid
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provides against base-sliding.

Since pullout failure of a geogrid involves local bearing failure on the front edges
of its ribs, ReActiv uses the bearing factor — and not the direct-shear factor — to
calculate a geogrid’s pullout resistance.

Soil nails

ReActiv uses the direct-shear factor to calculate the resistance that soil nails provide
against base-sliding and also — since pullout failure of soil nails involves sliding
along their circumference — their pullout resistance.

Custom reinforcement

Since you may want to specify certain types of geogrid as custom reinforcement
(perhaps to get around ReActiv’s validation checks), ReActiv uses the bearing
factor — and not the direct-shear factor — to calculate the pullout resistance of
custom reinforcement. This allows you to control the base-sliding and pullout
calculations independently of each other.

Calculation options

Interwedge friction factor

The angle of friction (φ12) that acts on the boundary between Wedges 1 and 2 (see
Chapter 9) is given by:

where φ is the angle of shearing resistance of the soil and fiwf is the interwedge
friction factor. ReActiv allows you to enter interwedge friction factors between 0
and 1.

Setting fiwf = 0 leads to conservative designs but has the advantage that the
equations used to calculate the out-of-balance force can be simplified, thereby
eliminating the need to decide on which wedge the reinforcement force acts (see
Chapter 9 for further discussion of this point).

When you want to minimize the conservatism in your design, you can enter a non-
zero value of fiwf. The out-of-balance force then depends on which wedge the
reinforcement force acts (see Chapter 9).
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Setting fiwf = 0.5 and assuming that all the reinforcement force acts on Wedge 2
provides a reasonable upper bound to results obtained using Caquot and Kerisel’s
charts and other methods (see Chapter 11). The agreement is less reasonable for
small slope angles.

Project information

ReActiv allows you to store project information in each file, so that you can keep
a record of the purpose and progress of your calculations.

The Project Information dialog box provides controls for entering your company’s
name and address, the project description and number, the engineer’s initials, a
revision letter and date, and notes about the current job.

Choose Edit > Project Info... to display the Project Information box.

Printing

ReActiv allows you to print your input and output data on a wide variety of printers
and to obtain a preview of the printout on your computer screen.

Print

The Print dialog box allows you to select various options for controlling what gets
printed and where it gets printed.
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You can display the Print dialog box by:

● Choosing File > Print... from the menu bar

● Clicking on the Print button on the Button Bar

The currently selected printer is displayed at the top of the dialog box. You can
change the properties of the printer by choosing the Properties... button.

Print preview

ReActiv provides a print preview facility, which allows you to see what will appear
on the printed page. This preview facility is extremely useful if you only want to
print a part of your input or output data, since it allows you to find out on which
page the required data will appear.

You can display the Print Preview window by:
● Choosing File > Print Preview... from the menu bar

● Clicking on the Print Preview button on the Button Bar
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Customizing the program

You can customize many of the default parameters that ReActiv provides in each
dialog box, by holding down the CTRL key and then clicking on the Defaults
button. ReActiv saves the values given in the dialog box in Windows’ Registry, for
later recall.

For further information, consult ReActiv’s help system.
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Calculating mechanisms

ReActiv performs calculations based on limit equilibrium analysis of the two-part
wedge mechanism described in Chapter 9.

ReActiv allows you to calculate the out-of-balance force for a single mechanism or
for a series of mechanisms set out on a grid. The program will also search
automatically for the mechanism that has the largest out-of-balance force (the Tmax

mechanism) and the basal mechanism that has a zero out-of-balance force (the Tob

mechanism). ReActiv uses these two mechanisms to determine the reinforcement
required to stabilize the slope (see Chapter 8).

The results of the calculations are displayed in the Mechanisms View, where they
can be inspected.

Mechanisms View

ReActiv displays the results of any stability calculations that you ask it to perform
in its Mechanisms View. This View is automatically created when you choose any
of the available options on the Calculate menu.
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The Mechanisms View displays the results of the calculations in a spreadsheet
containing, for each mechanism:

● The X- and Y- coordinate of the mechanism’s heel

● The angle of the upper wedge (θ1)

● The out-of-balance force or tension

● Notes indicating whether the mechanism is a critical mechanism, the Tmax

mechanism, or the Tob mechanism

● (Optionally) The mechanism’s type (defined below)

Mechanism types

A mechanism’s type depends on the positions of:

● The outcrop of Wedge 1

● The interwedge boundary

There are four possible mechanisms, as indicated in the following table.

Mechanism type Wedge 1 outcrops at... Interwedge boundary
outcrops at...

Standard Crest or upper slope Lower slope

Narrow Lower slope Lower slope

Wide Crest or upper slope Upper slope

Extra-wide Crest Crest

The following diagrams illustrate the various mechanism types:
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Distribution of reinforcement force

As discussed in Chapter 8, ReActiv provides two methods of calculating the
reinforcement force required to stabilize a mechanism. In the first method, it is
assumed that the reinforcement force acts solely on Wedge 1; and, in the second
method, it is assumed that the reinforcement force acts solely on Wedge 2.

You specify which method you want to use by selecting the appropriate options
on the Options menu:

● Tension on Wedge 1 selects the calculation method in which the
reinforcement force acts solely on Wedge 1



P a g e  |  2 8  R e A c t i v  2  U s e r  M a n u a l

● Tension on Wedge 2 selects the calculation method in which the
reinforcement force acts solely on Wedge 2

When you display the Options menu, a tick mark is shown next to the currently
selected option. By default, ReActiv puts all the reinforcement force on Wedge 2.

The assumption made about where the reinforcement force acts is irrelevant when
the reinforcement is horizontal (δ = 0)  and its interwedge friction factor (fiwf) is
zero, since the value of zeta (ζ) given in Chapter 9 is always equal to one.

In all other cases, however, it is necessary to choose between the two methods
provided. For most practical cases, it is reasonable to assume that the
reinforcement force acts on Wedge 2 (although this may not be so for small slope
angles when the interwedge factor is > 0 — see Chapter 9).

It can be shown for inclined reinforcement that placing all the reinforcement force
on Wedge 1 is always conservative. (Note that the design charts given in Table 4.1
of the Advice Note are based on this assumption.) However, applying all the
reinforcement force on Wedge 1 can be unnecessarily conservative for steeply
inclined soil nails (e.g. with angles of inclination > 10̊). As discussed in Chapter 9,
the alternative assumption that all the reinforcement force acts on Wedge 2 gives
reasonable design results provided the interwedge friction factor is less than or
equal to 0.5 and, for this reason, by default the program assumes all the
reinforcement force acts on Wedge 2.

Baseline

The baseline is a line that passes through the toe of the slope at an angle δ to the
horizontal (where δ is the angle of inclination of the reinforcement, measured
anticlockwise). For geogrids and geotextiles, δ is always zero; for soil nails and
User-defined reinforcement, δ may be greater than or equal to zero.

Invalid mechanisms

Invalid mechanisms are those whose:

● Heel position (X, Y) is outside the slope

● Heel position is below the lowest layer of reinforcements (i.e. the baseline,
defined below)

● Upper angle (θ1) is less than or equal to its lower angle (θ2) or greater than
90̊ – δ
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ReActiv displays the following error message if you attempt to calculate the out-of-
balance force for an invalid mechanism.

Calculating single mechanisms

You can calculate the out-of-balance force (T) for a single mechanism by choosing
Calculate > Single Mechanism... from the menu bar. If it has not already done so,
ReActiv creates the Mechanisms Window and then displays the dialog box shown.

The Single Mechanism box is a floating dialog
box that allows you to calculate the out-of-
balance force for a single mechanism. You
specify the X- and Y-coordinates of the
mechanism’s heel and the angle that the
upper wedge (Wedge 1) makes to the
horizontal (θ1) by entering appropriate values
into the X, Y, and Angle edit boxes.

When you choose the Calc button, ReActiv first of all checks whether the specified
mechanism is valid (see below) and — if it is — then:

● Calculates the out-of-balance force for that mechanism (which could be
positive or negative)

● Appends the result of the calculation to the list of mechanisms displayed in
the Mechanisms View
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Calculating grid mechanisms

You can calculate the out-of-balance force (T) for a series of mechanisms by
choosing Calculate > Grid Mechanisms... from the menu bar. If it has not already
done so, ReActiv creates the Mechanisms View and then displays the dialog box
shown.

The Grid Mechanisms box allows you to specify a series of uniformly spaced
gridlines, along which the program will perform successive calculations in order to
find the critical mechanism (see page 33) at each intersection point on the grid.
Only the critical mechanism for each grid point is displayed in the Mechanisms
View.

You do not need to use ReActiv’s grid feature in order to find the Tmax or Tob

mechanisms, since these are calculated for you automatically when you choose
Calculate > Tmax or Calculate > Tob from the menu bar.

When you choose the Calc button, ReActiv does the following:

● Displays a dialog box which keeps you informed as to the progress of the
calculations

● Performs a search for the most critical mechanism at each intersection point
on the grid and (when it has found it) displays that mechanism in the
Mechanisms View

● Updates the progress bar as each critical mechanism is found

● Allows you to cancel the remaining calculations by choosing the Cancel
button
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● Removes the dialogue box once all the calculations have been performed

Minimum and maximum co-ordinates

The starting and ending co-ordinates of the horizontal and vertical gridlines are
given in their respective Minimum and Maximum boxes. To alter the given values:

● Turn off the check mark in the Automatic box

● Enter your own values in the Minimum and Maximum boxes

To restore the original values in the Minimum and Maximum boxes:

● Turn on the check mark in the Automatic box

Number of lines

The number of gridlines in the horizontal and vertical directions are given in their
respective No of Lines boxes. To alter the given values:

● Turn off the check mark in the Automatic box

● Enter your own values in the No of Lines boxes

To restore the original values in the No of Lines boxes:

● Turn on the check mark in the Automatic box

When the number of gridlines in any direction is one, its maximum co-ordinate is
reset to its minimum, its Maximum box is disabled, and its Spacing box is hidden.

Spacing

ReActiv automatically calculates the spacing of the gridlines in each direction from
the appropriate minimum and maximum co-ordinates and number of lines. The
spacing is calculated from:
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Automatic grid

When the Automatic box is checked, ReActiv selects the most suitable grid for
multiple calculations by setting the grid co-ordinates and number of lines as
follows:

For the horizontal gridlines:

● Minimum co-ordinate = breadth of lower slope times the tangent of the
reinforcement’s angle of inclination

● Maximum co-ordinate = height of slope / 2

● No of lines = 11

For the vertical gridlines:

● Minimum co-ordinate = 0m

● Maximum co-ordinate = breadth of lower slope (i.e. H/tan β)

● No of lines = 11

Default grid

When you choose the Default button in the Grid Mechanisms box, ReActiv puts
the following default parameters in the appropriate edit boxes.

For the horizontal gridlines:

● Minimum co-ordinate = Ry

min
 times H

● Maximum co-ordinate = Ry

max
 times H

where H is the total height of the slope (to its crest).

For the vertical gridlines:

● Minimum co-ordinate = Rx

min
 times B

● Maximum = Rx

max
 times B

where B is the breadth of the slope.
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The various min. and max. ratios are taken from Window’s Registry. If you don’t
override the factory-supplied defaults, ReActiv uses the following values:

● Ry

min
  = 0

● Ry

max
 = 0.5

● Rx

min
  = 0

● Rx

max
  = 1.0

Critical mechanisms

For each point on the grid there is a fan of mechanisms, each with a different upper
wedge angle (θ1) and out-of-balance force (T). The critical mechanism is the one
that has the largest value of out-of-balance force (where ∂T/∂θ1 = 0).

Search algorithm

ReActiv searches for the critical mechanism within each fan using a variant of the
Golden Section Search algorithm, known as Brent’s Method. Brent’s Method uses
a technique called inverse parabolic interpolation to find the minimum (or
maximum) of a one-dimensional function. A full description of the method is given
by Press et al. (1992), Numerical recipes in C (2nd edition), Cambridge University
Press, pp397-402.

ReActiv indicates those mechanisms which are critical mechanisms by displaying
the word "Critical" in the Notes column of the Mechanisms View.
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Calculating the Tmax mechanism

You can find the largest out-of-balance force (Tmax) of any mechanism in the slope
by choosing Calculate > Tmax from the menu bar. If it has not already done so,
ReActiv creates the Mechanisms View and then begins searching for the Tmax

mechanism.

Searching for Tmax

The steps that ReActiv follows in searching for the Tmax mechanism are as follows:

● First, ReActiv displays a dialog box that keeps you informed about the
progress of the calculations (the number displayed in the progress bar is the
number of X, Y co-ordinates that have been considered in the search)

● Second, ReActiv performs a search for the critical mechanism (see page 33)
that has the largest out-of-balance force anywhere in the slope (you can
cancel the search for Tmax at any time by choosing the Cancel button in the
dialog box)

● Third, ReActiv repeats the search from a new starting point, in order to
ensure that its has not accidentally picked up a local maximum

● Fourth, ReActiv searches along the baseline for
the mechanism with the largest out-of-balance
force

● Fifth, ReActiv compares the body mechanism
with the baseline mechanism, and sets the Tmax

mechanism to be the one with the larger out-of-
balance force.

● Finally, ReActiv displays the result in a dialog
box.

When you click the OK button, ReActiv  dismisses this box and adds the Tmax

mechanism to the Mechanisms View. ReActiv marks the Tmax mechanism with the
word "Tmax" in the Notes column of the Mechanisms View.

Search algorithms

The search for Tmax in the body of the slope is performed using the Downhill
Simplex Method to find the minimum/ maximum of a two-dimensional function. A
full description of the method is given by Press et al. (1992), Numerical recipes in
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C (2nd edition), Cambridge University Press, pp408-412.

The search for Tmax along the baseline of the slope is performed using Brent’s
Method (see page 33).

Calculating the Tob mechanism

You can find the critical baseline mechanism that requires precisely zero
reinforcement force to establish its equilibrium (i.e. the Tob mechanism) by
choosing Calculate > Tob from the menu bar. If it has not already done so, ReActiv
creates the Mechanisms View and then begins searching for the Tob mechanism.

Searching for Tob

The steps that ReActiv follows in searching for the Tob mechanism are as follows:

● First, ReActiv searches along the baseline for the mechanism with the
largest out-of-balance force

● Second, ReActiv searches outwards from this point along the baseline for
the critical mechanism that has zero out-of-balance force

When it has found the Tob mechanism, ReActiv displays
the result in a dialog box.

When you choose the OK button, ReActiv dismisses
this box and adds the Tob mechanism to the
Mechanisms View. ReActiv marks the Tob mechanism
with the word "Tob" in the Notes column of the
Mechanisms View.

Search algorithm

ReActiv searches for the Tob mechanism using the method due to van Wijngaarden
et al., as improved by Brent. A full description of the method is given by Press et al.
(1992), Numerical recipes in C (2nd edition), Cambridge University Press, pp359-
362. The baseline Tmax mechanism is used in the initial bracketing of Tob, hence the
need to search for the baseline Tmax first.
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Calculating the required reinforcement

ReActiv determines the reinforcement required to stabilize a given slope based on
the results of the Tmax and Tob calculations described in Chapter 7.

ReActiv allows you to calculate the number of reinforcement layers required, their
optimum spacing, and their length. ReActiv also allows you to save on
reinforcement when using soil nails by decreasing the horizontal spacing of the top
row of nails. You can also choose to provide an extra layer of reinforcement at the
top of the slope, set a fixed vertical spacing between the layers of reinforcement
or change the wedge on which the tension is applied.

The required reinforcement layers are listed in the Reinforcement View and
displayed on the slope in the Job View.

Reinforcement View

ReActiv displays the required reinforcement layout in its Reinforcement View. This
View is automatically created when you choose Calculate > Reinforcement from
the menu bar.

The Reinforcement View displays the required reinforcement in a spreadsheet and
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gives, for each layer:

● The name of the reinforcement

● Its type

● Its strength

● The depth of the layer

● Its length

● Its inclination to the horizontal

● Notes giving special information relevant to that layer (for example, in the
case of soil nails, their horizontal spacing)

Calculating the required reinforcement

When you choose the Calculate > Reinforcement command, ReActiv performs a
number of calculations that culminate in the required reinforcement being
displayed in the Reinforcement View. These calculations are described in full in
Chapter 9 but, for convenience, are summarized below.

● First, a search is made for the Tmax mechanism (if it has not already been
found)

● Second, a search is made for the Tob mechanism (if it has not already been
found)

● Third, the total number of reinforcement layers (n) is calculated

● Fourth, the depth to the first layer of reinforcement (z1) is calculated

● Fifth, the pullout length of the first layer (Le1) is calculated

● Sixth, the depths of the remaining layers are calculated

● Finally, the lengths of these layers are calculated

Minimizing the length of soil nails

The Advice Note describes a method of reducing the length of soil nails by
decreasing the horizontal spacing of the first layer of nails and adjusting the length
of the other layers accordingly. The method is described in Chapter 9.

To minimize the length of soil nails, choose the Reduce Nail Lengths option from



P a g e  |  3 8  R e A c t i v  2  U s e r  M a n u a l

the Options menu in the Reinforcement View or click on the Reduce Nail Lengths
button on the Toolbar. ReActiv will then automatically reduce the horizontal
spacing of the top layer of nails when you next calculate the reinforcement. The
actual spacing adopted in the calculations is displayed in the Notes column of the
Reinforcement View.

Providing an additional layer at the top of the slope

When ReActiv optimizes the depths of the reinforcement layers, it places the first
layer of reinforcement at some depth below the top of the slope. Because of this,
there is the potential, particularly for Two-part or Infinite slopes, for the soil above
the first layer to be unstable. This instability can be avoided:

● In the case of geotextiles and geogrids, by providing a "wrap-around" front
face

● In the case of soil nails, by providing a mesh and shotcrete front face

In the absence of measures such as these to support the soil above the first layer,
it may be necessary to provide an extra layer of reinforcement at the top of the
slope. You can instruct ReActiv to provide this extra layer of reinforcement by
selecting the Extra Layer At Top command from the Reinforcement View’s
Options menu or by clicking on the Extra Layer At Top button on the Toolbar. A
tick mark is displayed next to this option when it is selected.

ReActiv asks you whether you want to provide an extra layer at the top of the
slope whenever both of the following conditions are met:

● The angle between the reinforcement and the upper slope of crest is
greater than or equal to 10̊

● The Extra Layer At Top option is not already selected Reinforcement View

Setting a the vertical spacing between the layers

When HA68/94 is selected on the Options menu, ReActiv calculates the vertical
spacing between reinforcement layers according to the optimised procedure given
in HA68 (see Chapter 9).

When the Fixed Vertical Spacing option is chosen on the Options menu, ReActiv
places the layers at a fixed spacing (which you specify), but allows more than one
strength of reinforcement to be used. At each depth, the program automatically
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selects the weakest layer that it can use to provide stability. The reinforcement
layers that the program uses and the spacing between them can be set via the
Reinforcement Used... command on the Options menu.

Tension on Wedge 1 or 2

ReActiv automatically specifies Wedge 2 as the wedge on which the tensions are
to be applied. However, the program allows you to change it if you wish to.

To change the wedge on which the tensions are applied, choose the Tension on
Wedge 1 option or the Tension on Wedge 2 option from the Options menu in the
Menu bar; alternatively, click on the Tension on Wedge 1 button or on the Tension
on Wedge 2 button on the Toolbar.
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